ページ

2012年11月18日日曜日

phpmyadmin 3.5.4 アップグレード


■phpmyadmin 3.5.4 アップグレード

「phpMyAdmin の新しいバージョンが提供されています。アップグレードの検討をお奨めします。最新バージョンは 3.5.4 で、2012-11-16 にリリースされています。」

phpmyadminにログインすると、上記のメッセージが表示されたのでVersion 3.5.4へアップグレード。

アップグレードについて、公式のドキュメント(https://docs.phpmyadmin.net/en/latest/setup.html#upgrading-from-an-older-version)には、下記のように記載されている。

Upgrading from an older version

Simply copy config.inc.php from your previous installation into the newly unpacked one. Configuration files from old versions may require some tweaking as some options have been changed or removed. For compatibility with PHP 6, remove a set_magic_quotes_runtime(0); statement that you might find near the end of your configuration file.

You should not copy libraries/config.default.php over config.inc.php because the default configuration file is version- specific.

If you have upgraded your MySQL server from a version previous to 4.1.2 to version 5.x or newer and if you use the phpMyAdmin configuration storage, you should run the SQL script found in examples/upgrade_tables_mysql_4_1_2+.sql.

古いバージョンからのアップグレード

単に以前のインストールから新しい展開先にconfig.inc.phpをコピーしてください。 古いバージョンのコンフィギュレーションファイルからいくつかのオプションが変更されたり削除されている為、いくつかの調整を必要とするかもしれません。 PHP 6との互換性のために、コンフィギュレーション·ファイルの終わり近くに見つけるかもしれない set_magic_quotes_runtime(0)を削除してください。

デフォルトの構成ファイルはバージョン固有であるため、config.inc.phpへlibraries/config.default.phpをコピーし てはいけません 。

あなたは、4.1.2より前のバージョンからバージョン5.x以降にMySQLサーバをアップグレードし、phpMyAdminのコンフィグレーション・ストレージを使用する場合は、examples/upgrade_tables_mysql_4_1_2+.sqlで発見したSQLスクリプトを実行する必要があります。

config.inc.phpファイルは基本的にそのまま使用可能な模様。
(今回のバージョンアップでファイル内容に変更は見られなかった)

1)ダウンロード

phpMyAdminのサイト(http://www.phpmyadmin.net/)から「phpMyAdmin 3.5.4」をダウンロード

phpMyAdmin-3.5.4-all-languages.zip (6.1 MiB)
http://www.phpmyadmin.net/home_page/downloads.php

2)インストール

インストール先”C:/usr/bin/Apache24/htdocs/phpMyAdmin”から、config.inc.phpを残して、それ以外を削除。
ZIPファイルを解凍し、すべてのファイルをインストール先”C:/usr/bin/Apache24/htdocs/phpMyAdmin”に移動。

3)動作確認

ブラウザから”http://localhost/phpMyAdmin/”へアクセスして、rootでログインし、
エラーが表示されない確認。

その他の投稿...